OpenWRT(二)配置WAN口和LAN口

OpenWRT 专栏收录该内容
15 篇文章 17 订阅

一、基本概念

  1. LAN:Local Area Network 的英文简称,即局域网
    我们计算机和路由连在一起就是接这个口

  2. WAN: Wide Area Network 的英文简称,即广域网
    运营商拉进来的网线就是和这个口连在一起

  3. VLAN( Virtual Local Area Network)的中文名为"虚拟局域网"
    VLAN通常是在局域网中逻辑地再划分为几个网段来构成VLAN。一个局域网中可以划分为N多个VLAN,使VLAN之间不可直接互相通信。LAN和WAN都属于VLAN

二、配置WAN口和LAN口

  1. 首先要将OpenWRT系统下载到开发板(RT5350),然后将开发板上电进入OpenWRT系统,使用secureCRT进行命令操作。(secureCRT对于熟悉Linux嵌入式开发的人应该so easy)

  2. OpenWRT中的配置文件在/etc/config/下面,WAN和LAN的配置在/etc/config/network中
    这里写图片描述
    上面是打开该文件后的截图

  3. 分析上面文件中的信息(只讲重点的):

  config interface 'lan'  //配置LAN口
    option type 'bridge' //桥接方式
    option ifname 'eth0.1' // 代表vlan1,这个很重要,下面配置会用到
    option proto 'static' //静态IP

   config device 'lan_dev' //配置LAN硬件信息
	   option macaddr           //设置MAC地址

   config interface 'wan'  //配置WAN口
	    option type 'dhcp' //dhcp方式(dhcp自行百度)

  config switch     //switch中文意思就开关,所以下面就是使能vlan口
		option enable_vlan  '1'    // 1表示开启vlan口

  config switch_vlan  
    option vlan '1'  //VLAN1, 和上面的option ifname 'eth0.1'相匹配,所以是配置LAN口
    option ports '0 1 2 3 6t'   //0~3都是LAN口,RT5350有5个端口

  config switch_vlan  
    option vlan '2'  //VLAN2, 和上面的option ifname 'eth0.2'相匹配,所以是配置WAN口
    option ports '4 6t'   //4是WAN口

好了,通过上面的介绍应该就能随意配置端口为LAN口或WAN口了

上面的network文件是UCI配置文件,要深入学习可以到https://wiki.openwrt.org/doc/uci

欢迎大家关注我的微信公众号!!
  • 2
    点赞
  • 0
    评论
  • 15
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

打赏
文章很值,打赏犒劳作者一下
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页

打赏

曼巴精神传承人

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值